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Introduction to DIgSILENT PowerFactory

1 Basics of PowerFactory
DIgSILENT's PowerFactory calculation program is a computer-aided planning and development tool for
analyzing electrical transmission, distribution and industrial grids. It has been developed as an
integrated, interactive software package with a rich set of functions for analyzing electrical power
supply systems and their control and regulation processes to meet all requirements in the areas of
planning and operational optimization.

1.1 Creation of a project
1. File> New=> Project
2. Definition of the grid and the nominal frequency
3. grid overview

1.2 Data Manager and Grid Model Manager

You can display data and organize it in the "browser interface". User actions performed in the grid
graph are also displayed in the data manager. You can duplicate similar models or resources using
Ctrl+c and Ctrl+v and adjust them accordingly.
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The grid model manager offers a clearly arranged view of all calculation-relevant objects with the
possibility to filter and change them. In the lower part of the manager there are the same tabs as when
creating the data in the grid graphic or the data manager. Under flexible data the load flow data can
be defined which are relevant for the investigations. Blue data is always the data that comes from the
last load flow calculation.
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1.3 Help and technical references

A comprehensive user manual is available for quick help. Either you can find it under Help—> User
manual or press F1 in the respective window for special questions. Also important are the technical
references to obtain information about the individual equipment such as transformers, synchronous
machines or static generators, but also to find important input and output parameters of the
equipment or measuring devices.

Example frequency measurement:

Table 2.1: Signals for Three-Phase Measurement (Balanced RMS-Simulation)

Name Symbol Unit | Type Description

ul pa. | IN Input Voltage, Real Part

ul pa. | IN Input Voltage, Imaginary Part

fref pau. | IN Reference Frequency (automatically connected)
Fmeas H- | OUT Measured Frequency

fmeas pau. | OUT Measured Frequency

xl STATE | State variable of the PI controller

2 rad | STATE | State variable of the integrator (Ph)

cosphi ouT cos(Phi)

sinphi ouT sin(Phi)

Here it is to be seen that one can obtain both the frequency in p.u. and in Hz as output of the frequency
meter.

1.4 Overview of the PowerFactory interface
In case of a newly created project, this and the calculation case will be activated automatically, and an
empty grid graphic will be displayed.
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In this figure you can see the following parts:
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1. The main menu bar as the first line of the window.

The main toolbar below 1. . It contains a list box that displays all available calculation cases. If
you select another calculation case in this list than before, this calculation case will be chosen.
If for space reasons not all buttons can be displayed in the window area, this toolbar is
displayed with small up-arrow and down-arrow buttons that can be used to display the
remaining buttons.

3. The local toolbar of the graphics window - just below the main toolbar - with its buttons. This
toolbar is also displayed with arrow buttons that can be used to make additional buttons visible
if the window is too small to display all the buttons. The icons available in this toolbar depend
on the content of the displayed window. In this case it is the graphics window with the grid
diagram.

4. The empty window with grid graphic and dotted lines.

5. The project overview. It shows an overview of the project and makes it easier for the user to
see the state of the project and allows quick access to the project data. If the window is not
displayed, it can be opened via Window—> Project overview (see main menu bar 1.).

6. The drawing toolbar, located to the right of the graphics window when docked.

7. The output window, which is the white window below the graphics window. The output
window displays text messages and text reports, as well as active links to detect and fix errors
in the data model.

8. The status bar (below 7.) for feedback on the current status of PowerFactory. The status bar
indicates, for example, the position of the cursor in the graphics window or else in the output
window. It also shows the name of the currently active project.

9. The navigation window. It shows an overview of the entire grid in a small window.
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2 Equipment (types) in PowerFactory
PowerFactory has a wide selection of defined equipment types for lines, transformers and synchronous
or asynchronous machines. These can be found in the Global Library at Types—> Device Name.

You can also create your own equipment types by creating a new type (see figure) under the local
library=> Equipment type library. Basic data such as the nominal voltage and the nominal apparent
power, but also the rated current and the specific parameters for e.g. cables can be stored here.
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3 Power (/Load) Flow Calculation

To test and evaluate the operation and control of power systems, the following aspects are of great importance:

e Are the voltages of each busbar in the system acceptable?

e  Whatis the loading of the various resources in the system (transformers, transmission lines, generators,
etc.)?

e How can | achieve the best possible (safe, reliable and economical) operation of the system?

e Does the system have one or more vulnerabilities? If so, where are these vulnerabilities located and
what countermeasures can | take?

Even considering that the above questions only arise when analyzing the behavior of existing power systems,
however, the same questions can be formulated when future systems or expansion stages of an existing system
need to be analyzed. For example, when the impact of the commissioning or outage/shutdown of a transmission
line or power plant needs to be evaluated. Furthermore, the issues mentioned above are also of greatimportance
for future grids with a high amount of renewable energies in the distribution grids. Thus, these plants can be
integrated into existing grids and their influence can be illustrated with power flow calculations.

A power flow calculation can be started from the main menu (Calculation - Load Flow—> Load Flow
...), with the shortcut (Ctrl +) F10 or by clicking the circled icon in the figure. This will open the Load
Flow command dialog, as shown in Figure 1.
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This command dialog offers various options for power flow calculation.

e The default settings for a power flow calculation consider the following options:
o Calculation method = AC load flow, symmetrical, co-system.
o Temperature dependence: line/cable resistances = ...at 20 cC
o Activate the option Consider active power limits
o Disable all other options on the Basic Options page.
o On the Active power control page: Set the active power control according to
the secondary control
e By confirming Execute, the load flow calculation is performed

Load Flow Calculation - Berechnungsfalle\Berechnungsfall\Lastflussberechnung.ComLdf ? > ]
Calculation Method 1'
Active Power Control ¢ AC Load Flow, balanced, positive sequence Close
Advanced Options (" AC Load Flow, unbalanced, 3-phase (ABC)
Calculation Settings (" DC Load Flow (linear) Cancel
Outputs Active Power Regulation
Load/Generation Scaling [ Automatic tap adjustment of phase shifters
Low Voltage Analysis [~ Consider active power limits

Voltage and Reactive Power Regulation
[~ Automatic tap adjustment of transformers
[~ Automatic tap adjustment of shunts

[~ Consider reactive power limits

Temperature Dependency: Line/Cable Resistances
f* ..at20°C

(" ...at Maximum Operational Temperature

Load Options
[~ Consider Voltage Dependency of Loads
[~ Feeder Load Scaling

Figure 1: Dialog box load flow calculation
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4 Short circuit calculation

Power supply systems are designed for reliable and safe grid operation. In order to be able to
guarantee this at all times, the adequate handling of short circuits is crucial. In general, the system is
designed in such a way that short circuits should not occur. However, this cannot always be guaranteed
due to, for example, a tree falling into the line or the failure of operating equipment.

One of the many applications of a short-circuit calculation is the testing of the rated values of
equipment in the planning phase of the grid. Here, the maximum and minimum currents to be
expected are of great importance for the design of the protective devices. The decisive factor here is
the short-circuit power Sk . In physical terms, this is not an actual power, since quantities are used for
the calculation that do not occur simultaneously. These are on the one hand the short-circuit current
I« and on the other hand the nominal voltage U, which is not present at the time of a short-circuit. The
short-circuit power is thus a rated quantity for quantifying the stress on an electrical system and, in
particular, the switching capacity of circuit breakers. A circuit breaker must have a breaking capacity
that is higher than the short-circuit capacity in order to be able to disconnect the current flow safely
and without damage to the breaker in the event of a short-circuit. There are different methods for the
calculation (IEC 60909/VDE 0102 or IEC 61363) which can be selected accordingly in PowerFactory.

Furthermore, PowerFactory's short-circuit calculation function can simulate both single and multiple
faults of almost unlimited complexity. In summary, besides power flow calculations, short circuit
calculation is one of the most frequently performed calculations when dealing with electrical grids. It
is used both in grid planning and in the operation of the grid.

There are several options for performing a short circuit calculation in PowerFactory:

e Calculation=> Short circuit—=> Short circuit calculation
o (Ctrl+)F11
e Circled symbol in the figure
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In the opening dialog window of the short-circuit calculation, both the calculation method and the type
of short-circuit (3-phase, 1-phase, ...) can be selected. As already mentioned, both the minimum and
maximum short-circuit currents can be calculated for the protection design.

Furthermore, the fault explanation time and the short-circuit time can be selected. The short-circuit
calculation can be performed for short-circuits at all nodes as well as at a specific busbar.
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5 Exercise Introduction PowerFactory

5.1 3-node grid

e Please import & activate the empty project template provided in moodle
o Import: File> Import—> Data (*.pfd,...)> Make selection—> Execute
o Activate: File=> Activate Project—> Select grid
o Tip: You should see an empty "sheet" now
e "Disable "Graphical Freeze Mode
o Click on the lock icon in the local toolbar of the graphics window
e Insert busbar (name: A) from the drawing tools
o Select a normal busbar (no system) for this, because then the required breakers are
added automatically and when inserting a device the field to be connected can be
selected
o Set nominal voltage Unenn = 380kV (double click on the busbar)
e Copy busbar A and pasteas Band C
e Insert connecting lines between inserted busbars A> B and A> C
o Assign operating equipment type: Double click on the line> "Type"-> Open dropdown
menu-> "Select Type"-> "Line Type"—> HVAC OHL 380kV
Length of the lines: A~ B: 100km and A= C: 50km
Creates the graphic layout according to the line length by dragging the busbars to a
different position
o Attention: Do not yet insert the connecting line B> C
e Add general loads to busbars B and C
o Load data for both loads: 100 MW
e Add external grid supply at node A
o Get to know Network Model Manager
o Select the Network Model Manager in the main toolbar (second icon from the left)>
View devices and their parameters
o Tip: Filtering operating resources is also possible

External Grid
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5.2 Power flow calculation (shortcut CTRL + F10)

Settings of the external grid:
o Double-click on the external grid=> Load Flow—> Bus Type: SL ("Slack" or "Ref node")
® Info: Fixed power taps, i.e. the external grid supplies the required active &
reactive power of the loads and the grid on the input side.
o Calculate the power flow
e (Calculate the power flow, open the Network Model Manager and answer the questions below
regarding:
o Loading of the lines
o Node voltages (magnitude and phase)
o Power losses in the grid
. Increase loads in 100MW steps to 1000MW
2. Set the loads to 1000MW and increases the reactive power up to 300Mvar.

External Grid

1002 4001
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0,152 0,152
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General Load General Load

Questions regarding trends:

1. Doesincreasing P_load or Q_load have a greater impact on line loading and does line length
matter?

2. Doesincreasing P_load or Q_load have a greater effect on the voltage drop at nodes B and C,
and what effect does the line length have?

3. Does increasing P_load or Q_load have a greater effect on the voltage angle at nodes B and
C, and what effect does the line length have?

Questions regarding exact values:

4. How much power loss is measured at 200MW and at 1000 MW in the grid?
5. How much additional reactive power must the external grid provide to supply the loads with
1000MW without reactive power or with 300Mvar?
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5.3 Short circuit calculation

In the next step, the generated grid is to be analyzed with a short circuit calculation. For this
purpose, select busbar B and first simulate a short circuit at this busbar.

o Right click-> Calculate—> Short circuit

o Answer question 1.
Then calculate the short circuit power at each busbar

o Select short circuit icon in main toolbar-> Fault location : Select "All busbars”

o Note: The short-circuit power of the external grid can be set under the Short-circuit

VDE/IEC tab and can also be found as a value in the model after the calculations.

o Answer question 2
Add a line between nodes B and C with the length of 50km to close the loop and achieve higher
meshing

o Answer question 3
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Questions:
1. What is the short-circuit power at node B if the short-circuit investigation is performed only
at node B, and what are the node voltages in p.u. at the other nodes?
2. What are the short-circuit powers of all nodes?
3. What are the short circuit powers of all nodes with line B-C? Explain the results.



	1 Basics of PowerFactory
	1.1 Creation of a project
	1.2 Data Manager and Grid Model Manager
	1.3 Help and technical references
	1.4 Overview of the PowerFactory interface

	2 Equipment (types) in PowerFactory
	3 Power (/Load) Flow Calculation
	4 Short circuit calculation
	5 Exercise Introduction PowerFactory
	5.1 3-node grid
	5.2 Power flow calculation (shortcut CTRL + F10)
	5.3 Short circuit calculation


